aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rb532/Makefile')
-rw-r--r--target/linux/rb532/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index c44ca7c993..e26c94bb2d 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci tgz
-LINUX_VERSION:=2.6.30.3
+LINUX_VERSION:=2.6.30.4
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
7'>107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222
diff -urN linux-2.6.19/arch/mips/Kconfig linux-2.6.19.new/arch/mips/Kconfig
--- linux-2.6.19/arch/mips/Kconfig	2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.new/arch/mips/Kconfig	2006-12-16 18:46:31.000000000 +0100
@@ -4,6 +4,10 @@
 	# Horrible source of confusion.  Die, die, die ...
 	select EMBEDDED
 
+config CFE
+       bool
+       # Common Firmware Environment
+
 mainmenu "Linux/MIPS Kernel Configuration"
 
 menu "Machine selection"
@@ -15,6 +15,18 @@
 	prompt "System type"
 	default SGI_IP22
 
+config BCM963XX 
+	bool "Support for Broadcom BCM963xx SoC"
+	select SYS_SUPPORTS_32BIT_KERNEL
+	select SYS_SUPPORTS_BIG_ENDIAN
+	select SYS_HAS_CPU_MIPS32_R1
+	select HW_HAS_PCI
+	select DMA_NONCOHERENT
+	select IRQ_CPU
+	select CFE
+	help
+	 This is a fmaily of boards based on the Broadcom MIPS32
+
 config MACH_ALCHEMY
 	bool "Alchemy processor based machines"
 
diff -urN linux-2.6.19/arch/mips/Makefile linux-2.6.19.new/arch/mips/Makefile
--- linux-2.6.19/arch/mips/Makefile	2006-12-16 17:36:29.000000000 +0100
+++ linux-2.6.19.new/arch/mips/Makefile	2006-12-16 18:46:31.000000000 +0100
@@ -158,6 +158,19 @@
 #
 
 #
+# Broadcom BCM963xx SoC
+#
+core-$(CONFIG_BCM963XX)	+= arch/mips/bcm963xx/
+cflags-$(CONFIG_BCM963XX)     	+= -Iinclude/asm-mips/mach-bcm963xx
+load-$(CONFIG_BCM963XX)	+= 0xffffffff80010000
+
+
+#
+# Common Firmware Environment
+#
+core-$(CONFIG_CFE)             += arch/mips/cfe/
+
+#
 # Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
 #
 core-$(CONFIG_MACH_JAZZ)	+= arch/mips/jazz/
diff -urN linux-2.6.19/arch/mips/kernel/cpu-probe.c linux-2.6.19.new/arch/mips/kernel/cpu-probe.c
--- linux-2.6.19/arch/mips/kernel/cpu-probe.c	2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.new/arch/mips/kernel/cpu-probe.c	2006-12-16 18:46:31.000000000 +0100
@@ -590,6 +590,28 @@
 		return;
 }
 
+static inline void cpu_probe_broadcom(struct cpuinfo_mips *c)