aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/patches/120-cf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rb532-2.6/patches/120-cf.patch')
-rw-r--r--target/linux/rb532-2.6/patches/120-cf.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/rb532-2.6/patches/120-cf.patch b/target/linux/rb532-2.6/patches/120-cf.patch
index 657d8157d0..f12b0a910d 100644
--- a/target/linux/rb532-2.6/patches/120-cf.patch
+++ b/target/linux/rb532-2.6/patches/120-cf.patch
@@ -1,7 +1,7 @@
diff -urN linux.old/drivers/block/Kconfig linux.dev/drivers/block/Kconfig
---- linux.old/drivers/block/Kconfig 2006-06-08 20:20:52.000000000 +0200
-+++ linux.dev/drivers/block/Kconfig 2006-06-08 22:14:58.000000000 +0200
-@@ -453,4 +453,12 @@
+--- linux.old/drivers/block/Kconfig 2006-10-26 02:43:39.000000000 +0200
++++ linux.dev/drivers/block/Kconfig 2006-10-26 00:11:14.000000000 +0200
+@@ -456,4 +456,12 @@
This driver provides Support for ATA over Ethernet block
devices like the Coraid EtherDrive (R) Storage Blade.
@@ -14,9 +14,18 @@ diff -urN linux.old/drivers/block/Kconfig linux.dev/drivers/block/Kconfig
+ device driver for it.
+
endmenu
+diff -urN linux.old/drivers/block/Makefile linux.dev/drivers/block/Makefile
+--- linux.old/drivers/block/Makefile 2006-06-18 03:49:35.000000000 +0200
++++ linux.dev/drivers/block/Makefile 2006-10-26 02:44:10.000000000 +0200
+@@ -29,4 +29,5 @@
+ obj-$(CONFIG_VIODASD) += viodasd.o
+ obj-$(CONFIG_BLK_DEV_SX8) += sx8.o
+ obj-$(CONFIG_BLK_DEV_UB) += ub.o
++obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb500/
+
diff -urN linux.old/drivers/block/rb500/ata.c linux.dev/drivers/block/rb500/ata.c
--- linux.old/drivers/block/rb500/ata.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/drivers/block/rb500/ata.c 2006-06-09 01:58:40.000000000 +0200
++++ linux.dev/drivers/block/rb500/ata.c 2006-10-26 00:11:14.000000000 +0200
@@ -0,0 +1,474 @@
+#include <linux/kernel.h> /* printk() */
+#include <linux/module.h> /* module to be loadable */
@@ -494,7 +503,7 @@ diff -urN linux.old/drivers/block/rb500/ata.c linux.dev/drivers/block/rb500/ata.
+/*eof*/
diff -urN linux.old/drivers/block/rb500/ata.h linux.dev/drivers/block/rb500/ata.h
--- linux.old/drivers/block/rb500/ata.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/drivers/block/rb500/ata.h 2006-06-09 00:15:23.000000000 +0200
++++ linux.dev/drivers/block/rb500/ata.h 2006-10-26 00:11:14.000000000 +0200
@@ -0,0 +1,132 @@
+#ifndef __CFMIPS_ATA_H__
+#define __CFMIPS_ATA_H__
@@ -630,7 +639,7 @@ diff -urN linux.old/drivers/block/rb500/ata.h linux.dev/drivers/block/rb500/ata.
+#endif
diff -urN linux.old/drivers/block/rb500/bdev.c linux.dev/drivers/block/rb500/bdev.c
--- linux.old/drivers/block/rb500/bdev.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/drivers/block/rb500/bdev.c 2006-06-15 16:29:04.000000000 +0200
++++ linux.dev/drivers/block/rb500/bdev.c 2006-10-26 00:11:14.000000000 +0200
@@ -0,0 +1,340 @@
+/* CF-mips driver
+ This is a block driver for the direct (mmaped) interface to the CF-slot,
@@ -974,17 +983,8 @@ diff -urN linux.old/drivers/block/rb500/bdev.c linux.dev/drivers/block/rb500/bde
+
diff -urN linux.old/drivers/block/rb500/Makefile linux.dev/drivers/block/rb500/Makefile
--- linux.old/drivers/block/rb500/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/drivers/block/rb500/Makefile 2006-06-08 22:14:58.000000000 +0200
++++ linux.dev/drivers/block/rb500/Makefile 2006-10-26 00:11:14.000000000 +0200
@@ -0,0 +1,3 @@
+## Makefile for the RB532 CF port
+
+obj-y += bdev.o ata.o
-diff -urN linux.old/drivers/Makefile linux.dev/drivers/Makefile
---- linux.old/drivers/Makefile 2006-06-08 20:20:52.000000000 +0200
-+++ linux.dev/drivers/Makefile 2006-06-08 22:14:58.000000000 +0200
-@@ -73,3 +73,4 @@
- obj-y += firmware/
- obj-$(CONFIG_CRYPTO) += crypto/
- obj-$(CONFIG_SUPERH) += sh/
-+obj-$(CONFIG_BLK_DEV_CF_MIPS) += block/rb500/
-\ No newline at end of file