aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch')
-rw-r--r--target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch b/target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch
new file mode 100644
index 0000000000..593743d7ba
--- /dev/null
+++ b/target/linux/rb1xx-2.6/patches/006-adm5120_gpio.patch
@@ -0,0 +1,25 @@
+diff -urN linux-2.6.19.2/drivers/char/Kconfig linux-2.6.19.2-adm5120/drivers/char/Kconfig
+--- linux-2.6.19.2/drivers/char/Kconfig 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2-adm5120/drivers/char/Kconfig 2007-01-23 01:13:39.000000000 +0100
+@@ -1034,7 +1034,9 @@
+ The mmtimer device allows direct userspace access to the
+ Altix system timer.
+
+-source "drivers/char/tpm/Kconfig"
++config ADM5120_GPIO
++ tristate "ADM5120 GPIO"
++ depends on MIPS_ADM5120
+
+ config TELCLOCK
+ tristate "Telecom clock driver for MPBL0010 ATCA SBC"
+diff -urN linux-2.6.19.2/drivers/char/Makefile linux-2.6.19.2-adm5120/drivers/char/Makefile
+--- linux-2.6.19.2/drivers/char/Makefile 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2-adm5120/drivers/char/Makefile 2007-01-23 01:20:01.000000000 +0100
+@@ -90,6 +90,7 @@
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_TANBAC_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
++obj-$(CONFIG_ADM5120_GPIO) += adm5120_gpio.o
+
+ obj-$(CONFIG_WATCHDOG) += watchdog/
+ obj-$(CONFIG_MWAVE) += mwave/