aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7621_iodata_wn-dx2033gr.dts40
-rw-r--r--target/linux/ramips/image/mt7621.mk9
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh3
3 files changed, 51 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7621_iodata_wn-dx2033gr.dts b/target/linux/ramips/dts/mt7621_iodata_wn-dx2033gr.dts
new file mode 100644
index 0000000000..ce02def7ff
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_iodata_wn-dx2033gr.dts
@@ -0,0 +1,40 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_iodata_wn-xx-xr.dtsi"
+
+/ {
+ compatible = "iodata,wn-dx2033gr", "mediatek,mt7621-soc";
+ model = "I-O DATA WN-DX2033GR";
+};
+
+&partitions {
+ partition@6b00000 {
+ label = "idmkey";
+ reg = <0x6b00000 0x0100000>;
+ read-only;
+ };
+
+ partition@6c00000 {
+ label = "Backup";
+ reg = <0x6c00000 0x1380000>;
+ read-only;
+ };
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ ieee80211-freq-limit = <2400000 2483000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 5710000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6e7391baef..d28aa96224 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -707,6 +707,15 @@ define Device/iodata_wn-dx1200gr
endef
TARGET_DEVICES += iodata_wn-dx1200gr
+define Device/iodata_wn-dx2033gr
+ $(Device/iodata_nand)
+ DEVICE_MODEL := WN-DX2033GR
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
+ uImage lzma -M 0x434f4d42 -n '3.10(XID.0)b30' | iodata-mstc-header
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += iodata_wn-dx2033gr
+
define Device/iodata_wn-gx300gr
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index ef9b680f32..a925dd0f18 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -84,7 +84,8 @@ platform_do_upgrade() {
;;
iodata,wn-ax1167gr2|\
iodata,wn-ax2033gr|\
- iodata,wn-dx1167r)
+ iodata,wn-dx1167r|\
+ iodata,wn-dx2033gr)
iodata_mstc_upgrade_prepare "0xfe75"
nand_do_upgrade "$1"
;;