aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7628an_asus_rt-ac1200-v2.dts32
-rw-r--r--target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dts131
-rw-r--r--target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dtsi138
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/02_network5
5 files changed, 188 insertions, 131 deletions
diff --git a/target/linux/ramips/dts/mt7628an_asus_rt-ac1200-v2.dts b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200-v2.dts
new file mode 100644
index 0000000000..2dd38fba4b
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200-v2.dts
@@ -0,0 +1,32 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_asus_rt-ac1200.dtsi"
+
+/ {
+ compatible = "asus,rt-ac1200-v2", "mediatek,mt7628an-soc";
+ model = "ASUS RT-AC1200 V2";
+};
+
+&state_default {
+ spis {
+ groups = "spis";
+ function = "spis";
+ };
+
+ gpio {
+ groups = "refclk", "i2c", "wled_an";
+ function = "gpio";
+ };
+};
+
+&usbphy {
+ status = "disabled";
+};
+
+&ehci {
+ status = "disabled";
+};
+
+&ohci {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dts b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dts
index dbb8302b85..abb86456da 100644
--- a/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dts
+++ b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dts
@@ -2,52 +2,15 @@
// Copyright (c) 2022 Ray Wang
// Copyright (c) 2022 Ivan Pavlov
-#include "mt7628an.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7628an_asus_rt-ac1200.dtsi"
/ {
compatible = "asus,rt-ac1200", "mediatek,mt7628an-soc";
model = "Asus RT-AC1200";
- aliases {
- led-boot = &led_power;
- led-failsafe = &led_power;
- led-running = &led_power;
- led-upgrade = &led_power;
- };
-
- keys {
- compatible = "gpio-keys";
-
- reset {
- label = "reset";
- gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_RESTART>;
- };
-
- wps {
- label = "wps";
- gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_WPS_BUTTON>;
- };
- };
-
leds {
compatible = "gpio-leds";
- led_power: power {
- label = "blue:power";
- gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
- };
-
- wlan2g {
- label = "blue:wlan2g";
- gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy0tpt";
- };
-
usb {
label = "blue:usb";
gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
@@ -55,98 +18,6 @@
linux,default-trigger = "usbport";
};
};
-
- gpio-export {
- compatible = "gpio-export";
- #size-cells = <0>;
-
- led-all {
- gpio-export,name = "led_all";
- gpio-export,output = <0>;
- gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <40000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "bootloader";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "nvram";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
-
- compatible = "nvmem-cells";
- #address-cells = <1>;
- #size-cells = <1>;
-
- macaddr_factory_28: macaddr@28 {
- reg = <0x28 0x6>;
- };
- };
-
- partition@50000 {
- compatible = "denx,uimage";
- label = "firmware";
- reg = <0x50000 0xfb0000>;
- };
- };
- };
-};
-
-&ethernet {
- nvmem-cells = <&macaddr_factory_28>;
- nvmem-cell-names = "mac-address";
-};
-
-&esw {
- mediatek,portmap = <0x3e>;
-};
-
-&wmac {
- status = "okay";
-
- mediatek,mtd-eeprom = <&factory 0x0>;
-};
-
-&pcie {
- status = "okay";
-};
-
-&pcie0 {
- wifi@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&factory 0x8000>;
- ieee80211-freq-limit = <5000000 6000000>;
-
- led {
- led-sources = <2>;
- led-active-low;
- };
- };
};
&state_default {
diff --git a/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dtsi b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dtsi
new file mode 100644
index 0000000000..d8d4245447
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_asus_rt-ac1200.dtsi
@@ -0,0 +1,138 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ led-boot = &led_wps;
+ led-failsafe = &led_wps;
+ led-running = &led_wps;
+ led-upgrade = &led_wps;
+ label-mac-device = &ethernet;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_wps: wps {
+ label = "blue:wps";
+ gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "blue:wlan2g";
+ gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <58000000>;
+ m25p,fast-read;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_4: macaddr@4 {
+ reg = <0x4 0x6>;
+ };
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+};
+
+&gpio {
+ enable-leds {
+ gpio-hog;
+ line-name = "enable-leds";
+ output-low;
+ gpios = <4 GPIO_ACTIVE_HIGH>;
+ };
+};
+
+&ethernet {
+ nvmem-cells = <&macaddr_factory_4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&esw {
+ mediatek,portmap = <0x3e>;
+};
+
+&wmac {
+ status = "okay";
+
+ mediatek,mtd-eeprom = <&factory 0x0>;
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ mt76@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+
+ led {
+ led-sources = <2>;
+ led-active-low;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index bd91bd9340..81b68f6354 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -47,6 +47,19 @@ define Device/asus_rt-ac1200
endef
TARGET_DEVICES += asus_rt-ac1200
+define Device/asus_rt-ac1200-v2
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Asus
+ DEVICE_MODEL := RT-AC1200
+ DEVICE_VARIANT := V2
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+endef
+TARGET_DEVICES += asus_rt-ac1200-v2
+
define Device/asus_rt-n10p-v3
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Asus
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index 1f833c1820..408f5f5e01 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -35,6 +35,7 @@ ramips_setup_interfaces()
ucidef_set_interface_lan "eth0"
;;
asus,rt-ac1200|\
+ asus,rt-ac1200-v2|\
hilink,hlk-7628n|\
hilink,hlk-7688a|\
hiwifi,hc5861b|\
@@ -178,7 +179,9 @@ ramips_setup_macs()
local label_mac=""
case $board in
- asus,rt-ac1200|\
+ asus,rt-ac1200)
+ wan_mac=$(mtd_get_mac_binary factory 0x22)
+ ;;
elecom,wrc-1167fs)
wan_mac=$(mtd_get_mac_binary factory 0x22)
label_mac=$wan_mac