aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7621_mts_wg430223.dts8
-rw-r--r--target/linux/ramips/image/mt7621.mk21
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh1
5 files changed, 35 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/mt7621_mts_wg430223.dts b/target/linux/ramips/dts/mt7621_mts_wg430223.dts
new file mode 100644
index 0000000000..9ddb1d8dc5
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_mts_wg430223.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_arcadyan_wg4xx223.dtsi"
+
+/ {
+ compatible = "mts,wg430223", "mediatek,mt7621-soc";
+ model = "MTS WG430223";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 7b78d9fdcc..860b33d1dd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1201,6 +1201,27 @@ define Device/mtc_wr1201
endef
TARGET_DEVICES += mtc_wr1201
+define Device/mts_wg430223
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ DEVICE_VENDOR := MTS
+ DEVICE_MODEL := WG430223
+ IMAGE_SIZE := 32768k
+ KERNEL_SIZE := 4352k
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
+ uImage none | arcadyan-trx 0x53485231 | pad-to $$(KERNEL_SIZE)
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
+ uImage none
+ IMAGES += factory.trx
+ IMAGE/factory.trx := append-kernel | append-ubi | check-size
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware uboot-envtools
+endef
+TARGET_DEVICES += mts_wg430223
+
define Device/netgear_ex6150
$(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 0c696b2301..ae8ee89d7f 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -47,6 +47,7 @@ ramips_setup_interfaces()
jcg,q20|\
lenovo,newifi-d1|\
mikrotik,routerboard-m33g|\
+ mts,wg430223|\
oraybox,x3a|\
renkforce,ws-wn530hp3-a|\
xiaomi,mi-router-3g|\
@@ -128,7 +129,8 @@ ramips_setup_macs()
wan_mac=$(mtd_get_mac_ascii u-boot-env et1macaddr)
label_mac=$(mtd_get_mac_binary factory 0x4)
;;
- beeline,smartbox-flash)
+ beeline,smartbox-flash|\
+ mts,wg430223)
lan_mac=$(mtd_get_mac_ascii u-boot-env eth2macaddr)
wan_mac=$(mtd_get_mac_ascii u-boot-env eth3macaddr)
label_mac=$lan_mac
diff --git a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index e54d166dea..265cd2eb28 100644
--- a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -10,7 +10,8 @@ PHYNBR=${DEVPATH##*/phy}
board=$(board_name)
case "$board" in
- beeline,smartbox-flash)
+ beeline,smartbox-flash|\
+ mts,wg430223)
hw_mac_addr_ra0="$(mtd_get_mac_ascii u-boot-env ra0macaddr)"
hw_mac_addr_rax0="$(mtd_get_mac_ascii u-boot-env rax0macaddr)"
[ "$PHYNBR" = "0" ] && echo -n $hw_mac_addr_ra0 > /sys${DEVPATH}/macaddress
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index 1744c894c4..cf3caff702 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -71,6 +71,7 @@ platform_do_upgrade() {
linksys,ea7500-v2|\
linksys,ea8100-v1|\
linksys,ea8100-v2|\
+ mts,wg430223|\
netgear,r6220|\
netgear,r6260|\
netgear,r6350|\