aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7628an_glinet_microuter-n300.dts21
-rw-r--r--target/linux/ramips/dts/mt7628an_glinet_vixmini.dts99
-rw-r--r--target/linux/ramips/dts/mt7628an_glinet_vixmini_microuter.dtsi104
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network1
5 files changed, 142 insertions, 91 deletions
diff --git a/target/linux/ramips/dts/mt7628an_glinet_microuter-n300.dts b/target/linux/ramips/dts/mt7628an_glinet_microuter-n300.dts
new file mode 100644
index 0000000000..5a965f96bc
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_glinet_microuter-n300.dts
@@ -0,0 +1,21 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an_glinet_vixmini_microuter.dtsi"
+
+/ {
+ compatible = "glinet,microuter-n300", "mediatek,mt7628an-soc";
+ model = "GL.iNet microuter-N300";
+};
+
+&led_power_blue {
+ label = "microuter-n300:blue:power";
+};
+
+&led_wlan_white {
+ label = "microuter-n300:white:wlan";
+};
+
+&firmware_part {
+ reg = <0x50000 0xfb0000>;
+};
diff --git a/target/linux/ramips/dts/mt7628an_glinet_vixmini.dts b/target/linux/ramips/dts/mt7628an_glinet_vixmini.dts
index 0935ec869b..770998a87a 100644
--- a/target/linux/ramips/dts/mt7628an_glinet_vixmini.dts
+++ b/target/linux/ramips/dts/mt7628an_glinet_vixmini.dts
@@ -1,104 +1,21 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7628an.dtsi"
+#include "mt7628an_glinet_vixmini_microuter.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/{
+/ {
compatible = "glinet,vixmini", "mediatek,mt7628an-soc";
model = "GL.iNet VIXMINI";
-
- aliases {
- led-boot = &led_power;
- led-failsafe = &led_power;
- led-running = &led_power;
- led-upgrade = &led_power;
- };
-
- chosen {
- bootargs = "console=ttyS0,115200";
- };
-
- leds {
- compatible = "gpio-leds";
-
- led_power: power {
- label = "vixmini:blue:power";
- default-state = "on";
- gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
- };
-
- wlan {
- label = "vixmini:white:wlan";
- gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy0tpt";
- };
- };
-
- keys {
- compatible = "gpio-keys";
-
- reset {
- label = "reset";
- gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_RESTART>;
- };
- };
};
-&state_default {
- gpio {
- ralink,group = "wdt", "wled_an", "p1led_an";
- ralink,function = "gpio";
- };
+&led_power_blue {
+ label = "vixmini:blue:power";
};
-&ethernet {
- mtd-mac-address = <&factory 0x4>;
+&led_wlan_white {
+ label = "vixmini:white:wlan";
};
-&wmac {
- status = "okay";
-};
-
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <10000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- compatible = "denx,uimage";
- label = "firmware";
- reg = <0x50000 0x7b0000>;
- };
- };
- };
+&firmware_part {
+ reg = <0x50000 0x7b0000>;
};
diff --git a/target/linux/ramips/dts/mt7628an_glinet_vixmini_microuter.dtsi b/target/linux/ramips/dts/mt7628an_glinet_vixmini_microuter.dtsi
new file mode 100644
index 0000000000..b88f9e7356
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_glinet_vixmini_microuter.dtsi
@@ -0,0 +1,104 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ led-boot = &led_power_blue;
+ led-failsafe = &led_power_blue;
+ led-running = &led_power_blue;
+ led-upgrade = &led_power_blue;
+
+ label-mac-device = &ethernet;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power_blue: power {
+ /* Name is set device-specific */
+ gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wlan_white: wlan {
+ /* Name is set device-specific */
+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ ralink,group = "wdt", "wled_an", "p1led_an";
+ ralink,function = "gpio";
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+};
+
+&wmac {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ /*
+ * Firmware-partition size is model-specific
+ * due to different flash sizes.
+ */
+ firmware_part: partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ };
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5ddeec14d5..37cac84229 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -70,6 +70,14 @@ define Device/glinet_gl-mt300n-v2
endef
TARGET_DEVICES += glinet_gl-mt300n-v2
+define Device/glinet_microuter-n300
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := microuter-N300
+ SUPPORTED_DEVICES += microuter-n300
+endef
+TARGET_DEVICES += glinet_microuter-n300
+
define Device/glinet_vixmini
IMAGE_SIZE := 7872k
DEVICE_VENDOR := GL.iNet
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index b036eb76e6..259a257f16 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -33,6 +33,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan" "0:wan" "6@eth0"
;;
+ glinet,microuter-n300|\
glinet,vixmini)
ucidef_add_switch "switch0" \
"0:lan" "6@eth0"