aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_archer-c20-v5.dts98
-rw-r--r--target/linux/ramips/image/mt76x8.mk15
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network2
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/lib/upgrade/platform.sh1
5 files changed, 118 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7628an_tplink_archer-c20-v5.dts b/target/linux/ramips/dts/mt7628an_tplink_archer-c20-v5.dts
new file mode 100644
index 0000000000..e01826841d
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_archer-c20-v5.dts
@@ -0,0 +1,98 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an_tplink_8m-split-uboot.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "tplink,archer-c20-v5", "mediatek,mt7628an-soc";
+ model = "TP-Link Archer C20 v5";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "archer-c20-v5:green:power";
+ gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "archer-c20-v5:green:wlan2g";
+ gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g {
+ label = "archer-c20-v5:green:wlan5g";
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ lan {
+ label = "archer-c20-v5:green:lan";
+ gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_green {
+ label = "archer-c20-v5:green:wan";
+ gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_orange {
+ label = "archer-c20-v5:orange:wan";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "archer-c20-v5:green:wps";
+ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ ralink,group = "i2s", "gpio", "refclk", "p0led_an", "p1led_an",
+ "p2led_an", "p3led_an", "p4led_an", "wdt";
+ ralink,function = "gpio";
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ mtd-mac-address = <&rom 0xf100>;
+ mtd-mac-address-increment = <(-1)>;
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 2b5ec60a90..f3a948bf11 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -282,6 +282,21 @@ define Device/tplink_archer-c20-v4
endef
TARGET_DEVICES += tplink_archer-c20-v4
+define Device/tplink_archer-c20-v5
+ $(Device/tplink)
+ IMAGE_SIZE := 7616k
+ DEVICE_MODEL := Archer C20
+ DEVICE_VARIANT := v5
+ TPLINK_FLASHLAYOUT := 8MSUmtk
+ TPLINK_HWID := 0xc200005
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-mt76x0e
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += tplink_archer-c20-v5
+
define Device/tplink_archer-c50-v3
$(Device/tplink)
IMAGE_SIZE := 7808k
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index 06b78eb195..79f45ba545 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -52,7 +52,8 @@ tama,w06)
ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
ucidef_set_led_wlan "wlan" "WLAN" "$boardname:green:wlan" "phy0tpt"
;;
-tplink,archer-c20-v4)
+tplink,archer-c20-v4|\
+tplink,archer-c20-v5)
ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
;;
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index a733353f71..646e29235c 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -40,6 +40,7 @@ ramips_setup_interfaces()
hiwifi,hc5861b|\
skylab,skw92a|\
tplink,archer-c20-v4|\
+ tplink,archer-c20-v5|\
tplink,archer-c50-v3|\
tplink,archer-c50-v4|\
tplink,tl-mr3420-v5|\
@@ -191,6 +192,7 @@ ramips_setup_macs()
tplink,tl-wr842n-v5)
wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 0xf100)" 1)
;;
+ tplink,archer-c20-v5|\
tplink,archer-c50-v4)
wan_mac=$(macaddr_add "$(mtd_get_mac_binary rom 0xf100)" 1)
;;
diff --git a/target/linux/ramips/mt76x8/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt76x8/base-files/lib/upgrade/platform.sh
index a3de97abf7..20adfafc3d 100755
--- a/target/linux/ramips/mt76x8/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt76x8/base-files/lib/upgrade/platform.sh
@@ -28,6 +28,7 @@ platform_do_upgrade() {
}
default_do_upgrade "$1"
;;
+ tplink,archer-c20-v5|\
tplink,archer-c50-v4)
MTD_ARGS="-t romfile"
default_do_upgrade "$1"