aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/patches-3.10')
-rw-r--r--target/linux/ramips/patches-3.10/0211-watchdog-add-MT7621-support.patch22
-rw-r--r--target/linux/ramips/patches-3.10/0212-GPIO-ralink-add-mt7621-gpio-controller.patch30
-rw-r--r--target/linux/ramips/patches-3.10/0217-pinmux-rt2880.patch10
3 files changed, 23 insertions, 39 deletions
diff --git a/target/linux/ramips/patches-3.10/0211-watchdog-add-MT7621-support.patch b/target/linux/ramips/patches-3.10/0211-watchdog-add-MT7621-support.patch
index dde4a35aef..d010f6fab0 100644
--- a/target/linux/ramips/patches-3.10/0211-watchdog-add-MT7621-support.patch
+++ b/target/linux/ramips/patches-3.10/0211-watchdog-add-MT7621-support.patch
@@ -11,11 +11,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 193 insertions(+)
create mode 100644 drivers/watchdog/mt7621_wdt.c
-Index: linux-3.10.32/drivers/watchdog/Kconfig
-===================================================================
---- linux-3.10.32.orig/drivers/watchdog/Kconfig 2014-03-18 11:00:30.629639835 +0000
-+++ linux-3.10.32/drivers/watchdog/Kconfig 2014-03-18 11:02:35.141634769 +0000
-@@ -1120,6 +1120,13 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1120,6 +1120,13 @@ config RALINK_WDT
help
Hardware driver for the Ralink SoC Watchdog Timer.
@@ -29,11 +27,9 @@ Index: linux-3.10.32/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
-Index: linux-3.10.32/drivers/watchdog/Makefile
-===================================================================
---- linux-3.10.32.orig/drivers/watchdog/Makefile 2014-03-18 11:00:30.629639835 +0000
-+++ linux-3.10.32/drivers/watchdog/Makefile 2014-03-18 11:00:31.317639807 +0000
-@@ -136,6 +136,7 @@
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -136,6 +136,7 @@ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
obj-$(CONFIG_RALINK_WDT) += rt2880_wdt.o
@@ -41,10 +37,8 @@ Index: linux-3.10.32/drivers/watchdog/Makefile
# PARISC Architecture
-Index: linux-3.10.32/drivers/watchdog/mt7621_wdt.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.32/drivers/watchdog/mt7621_wdt.c 2014-03-18 11:00:31.317639807 +0000
+--- /dev/null
++++ b/drivers/watchdog/mt7621_wdt.c
@@ -0,0 +1,185 @@
+/*
+ * Ralink RT288x/RT3xxx/MT76xx built-in hardware watchdog timer
diff --git a/target/linux/ramips/patches-3.10/0212-GPIO-ralink-add-mt7621-gpio-controller.patch b/target/linux/ramips/patches-3.10/0212-GPIO-ralink-add-mt7621-gpio-controller.patch
index 5a554fd349..e0a0db81ad 100644
--- a/target/linux/ramips/patches-3.10/0212-GPIO-ralink-add-mt7621-gpio-controller.patch
+++ b/target/linux/ramips/patches-3.10/0212-GPIO-ralink-add-mt7621-gpio-controller.patch
@@ -12,11 +12,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
4 files changed, 194 insertions(+), 1 deletion(-)
create mode 100644 drivers/gpio/gpio-mt7621.c
-Index: linux-3.10.32/arch/mips/Kconfig
-===================================================================
---- linux-3.10.32.orig/arch/mips/Kconfig 2014-03-18 11:00:30.945639822 +0000
-+++ linux-3.10.32/arch/mips/Kconfig 2014-03-18 11:00:31.325639806 +0000
-@@ -448,7 +448,10 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -448,7 +448,10 @@ config RALINK
select ARCH_REQUIRE_GPIOLIB
select PINCTRL
select PINCTRL_RT2880
@@ -28,11 +26,9 @@ Index: linux-3.10.32/arch/mips/Kconfig
config SGI_IP22
bool "SGI IP22 (Indy/Indigo2)"
select FW_ARC
-Index: linux-3.10.32/drivers/gpio/Kconfig
-===================================================================
---- linux-3.10.32.orig/drivers/gpio/Kconfig 2014-03-18 11:00:30.653639834 +0000
-+++ linux-3.10.32/drivers/gpio/Kconfig 2014-03-18 11:02:01.901636126 +0000
-@@ -710,6 +710,12 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -710,6 +710,12 @@ config GPIO_MSIC
Enable support for GPIO on intel MSIC controllers found in
intel MID devices
@@ -45,19 +41,15 @@ Index: linux-3.10.32/drivers/gpio/Kconfig
comment "USB GPIO expanders:"
config GPIO_VIPERBOARD
-Index: linux-3.10.32/drivers/gpio/Makefile
-===================================================================
---- linux-3.10.32.orig/drivers/gpio/Makefile 2014-03-18 11:00:30.653639834 +0000
-+++ linux-3.10.32/drivers/gpio/Makefile 2014-03-18 11:00:31.325639806 +0000
-@@ -88,3 +88,4 @@
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -88,3 +88,4 @@ obj-$(CONFIG_GPIO_WM831X) += gpio-wm831x
obj-$(CONFIG_GPIO_WM8350) += gpio-wm8350.o
obj-$(CONFIG_GPIO_WM8994) += gpio-wm8994.o
obj-$(CONFIG_GPIO_XILINX) += gpio-xilinx.o
+obj-$(CONFIG_GPIO_MT7621) += gpio-mt7621.o
-Index: linux-3.10.32/drivers/gpio/gpio-mt7621.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.32/drivers/gpio/gpio-mt7621.c 2014-03-18 11:00:31.325639806 +0000
+--- /dev/null
++++ b/drivers/gpio/gpio-mt7621.c
@@ -0,0 +1,183 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
diff --git a/target/linux/ramips/patches-3.10/0217-pinmux-rt2880.patch b/target/linux/ramips/patches-3.10/0217-pinmux-rt2880.patch
index 05d95484da..3cadce737d 100644
--- a/target/linux/ramips/patches-3.10/0217-pinmux-rt2880.patch
+++ b/target/linux/ramips/patches-3.10/0217-pinmux-rt2880.patch
@@ -1,7 +1,5 @@
-Index: linux-3.10.32/arch/mips/ralink/rt288x.c
-===================================================================
---- linux-3.10.32.orig/arch/mips/ralink/rt288x.c 2014-02-22 20:41:54.000000000 +0000
-+++ linux-3.10.32/arch/mips/ralink/rt288x.c 2014-03-18 11:18:06.689596876 +0000
+--- a/arch/mips/ralink/rt288x.c
++++ b/arch/mips/ralink/rt288x.c
@@ -17,46 +17,27 @@
#include <asm/mipsregs.h>
#include <asm/mach-ralink/ralink_regs.h>
@@ -67,7 +65,7 @@ Index: linux-3.10.32/arch/mips/ralink/rt288x.c
};
static void rt288x_wdt_reset(void)
-@@ -69,11 +50,6 @@
+@@ -69,11 +50,6 @@ static void rt288x_wdt_reset(void)
rt_sysc_w32(t, SYSC_REG_CLKCFG);
}
@@ -79,7 +77,7 @@ Index: linux-3.10.32/arch/mips/ralink/rt288x.c
void __init ralink_clk_init(void)
{
unsigned long cpu_rate;
-@@ -140,4 +116,6 @@
+@@ -140,4 +116,6 @@ void prom_soc_init(struct ralink_soc_inf
soc_info->mem_base = RT2880_SDRAM_BASE;
soc_info->mem_size_min = RT2880_MEM_SIZE_MIN;
soc_info->mem_size_max = RT2880_MEM_SIZE_MAX;