aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch17
1 files changed, 4 insertions, 13 deletions
diff --git a/target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch b/target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch
index 77606cf385..578e614aac 100644
--- a/target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch
+++ b/target/linux/ramips/patches-3.10/0031-owrt-MIPS-add-OWRTDTB-secion.patch
@@ -10,13 +10,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
arch/mips/ralink/of.c | 4 +++-
3 files changed, 7 insertions(+), 2 deletions(-)
-diff --git a/arch/mips/kernel/head.S b/arch/mips/kernel/head.S
-index c61cdae..b4e55bb 100644
--- a/arch/mips/kernel/head.S
+++ b/arch/mips/kernel/head.S
-@@ -140,6 +140,9 @@ FEXPORT(__kernel_entry)
- j kernel_entry
- #endif
+@@ -146,6 +146,9 @@ EXPORT(__image_cmdline)
+ .fill 0x400
+ #endif /* CONFIG_IMAGE_CMDLINE_HACK */
+ .ascii "OWRTDTB:"
+ EXPORT(__image_dtb)
@@ -24,18 +22,14 @@ index c61cdae..b4e55bb 100644
__REF
NESTED(kernel_entry, 16, sp) # kernel entry point
-diff --git a/arch/mips/ralink/Makefile b/arch/mips/ralink/Makefile
-index 03af636..9b32626 100644
--- a/arch/mips/ralink/Makefile
+++ b/arch/mips/ralink/Makefile
-@@ -19,4 +19,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+@@ -19,4 +19,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
obj-$(CONFIG_DEBUG_FS) += bootrom.o
-obj-y += dts/
+#obj-y += dts/
-diff --git a/arch/mips/ralink/of.c b/arch/mips/ralink/of.c
-index 2faf478..d87222f 100644
--- a/arch/mips/ralink/of.c
+++ b/arch/mips/ralink/of.c
@@ -83,6 +83,8 @@ void __init device_tree_init(void)
@@ -56,6 +50,3 @@ index 2faf478..d87222f 100644
if (soc_info.mem_size)
add_memory_region(soc_info.mem_base, soc_info.mem_size * SZ_1M,
---
-1.7.10.4
-