aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch')
-rw-r--r--target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch b/target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch
new file mode 100644
index 0000000000..71d11c47a5
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.30/100-mips-ralink-core.patch
@@ -0,0 +1,43 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -603,6 +603,20 @@ else
+ load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+ endif
+
++#
++# Ralink RT288x
++#
++core-$(CONFIG_RALINK_RT288X) += arch/mips/ralink/rt288x/
++cflags-$(CONFIG_RALINK_RT288X) += -I$(srctree)/arch/mips/include/asm/mach-ralink
++load-$(CONFIG_RALINK_RT288X) += 0xffffffff88000000
++
++#
++# Ralink RT305x
++#
++core-$(CONFIG_RALINK_RT305X) += arch/mips/ralink/rt305x/
++cflags-$(CONFIG_RALINK_RT305X) += -I$(srctree)/arch/mips/include/asm/mach-ralink
++load-$(CONFIG_RALINK_RT305X) += 0xffffffff80000000
++
+ # temporary until string.h is fixed
+ cflags-y += -ffreestanding
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -22,6 +22,9 @@ choice
+ config MACH_ALCHEMY
+ bool "Alchemy processor based machines"
+
++config MIPS_RALINK
++ bool "Ralink MIPS SoC based boards"
++
+ config BASLER_EXCITE
+ bool "Basler eXcite smart camera"
+ select CEVT_R4K
+@@ -638,6 +641,7 @@ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+ source "arch/mips/lasat/Kconfig"
+ source "arch/mips/pmc-sierra/Kconfig"
++source "arch/mips/ralink/Kconfig"
+ source "arch/mips/sgi-ip27/Kconfig"
+ source "arch/mips/sibyte/Kconfig"
+ source "arch/mips/txx9/Kconfig"