aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 94fc85ed1a..e86c86cf11 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -940,6 +940,23 @@ define Device/xiaomi_mir3p
endef
TARGET_DEVICES += xiaomi_mir3p
+define Device/xiaomi_redmi-router-ac2100
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 124416k
+ UBINIZE_OPTS := -E 5
+ IMAGES += kernel1.bin rootfs0.bin
+ IMAGE/kernel1.bin := append-kernel
+ IMAGE/rootfs0.bin := append-ubi | check-size
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_MODEL := Redmi Router AC2100
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e wpad-basic uboot-envtools
+endef
+TARGET_DEVICES += xiaomi_redmi-router-ac2100
+
define Device/xiaoyu_xy-c5
IMAGE_SIZE := 32448k
DEVICE_VENDOR := XiaoYu