aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index a77f1c97e1..9db2d9e60c 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -320,6 +320,18 @@ define Device/jotale_js76x8-32m
endef
TARGET_DEVICES += jotale_js76x8-32m
+define Device/keenetic_kn-1613
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 31488k
+ DEVICE_VENDOR := Keenetic
+ DEVICE_MODEL := KN-1613
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to $$$$(BLOCKSIZE) | \
+ check-size | zyimage -d 0x801613 -v "KN-1613"
+endef
+TARGET_DEVICES += keenetic_kn-1613
+
define Device/kroks_kndrt31r16
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Kroks