aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk32
1 files changed, 21 insertions, 11 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c3b9bc9f6b..bfc7fa7db0 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -807,6 +807,27 @@ define Device/ohyeah_oy-0001
endef
TARGET_DEVICES += ohyeah_oy-0001
+define Device/phicomm_k2-v22.4
+ SOC := mt7620a
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Phicomm
+ DEVICE_MODEL := K2
+ DEVICE_VARIANT:= v22.4 or older
+ DEVICE_PACKAGES := kmod-mt76x2
+ SUPPORTED_DEVICES += psg1218 psg1218a phicomm,psg1218a
+endef
+TARGET_DEVICES += phicomm_k2-v22.4
+
+define Device/phicomm_k2-v22.5
+ SOC := mt7620a
+ IMAGE_SIZE := 7552k
+ DEVICE_VENDOR := Phicomm
+ DEVICE_MODEL := K2
+ DEVICE_VARIANT:= v22.5 or newer
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += phicomm_k2-v22.5
+
define Device/phicomm_k2g
SOC := mt7620a
IMAGE_SIZE := 7552k
@@ -826,17 +847,6 @@ define Device/phicomm_psg1208
endef
TARGET_DEVICES += phicomm_psg1208
-define Device/phicomm_psg1218a
- SOC := mt7620a
- IMAGE_SIZE := 7872k
- DEVICE_VENDOR := Phicomm
- DEVICE_MODEL := PSG1218
- DEVICE_VARIANT:= Ax
- DEVICE_PACKAGES := kmod-mt76x2
- SUPPORTED_DEVICES += psg1218 psg1218a
-endef
-TARGET_DEVICES += phicomm_psg1218a
-
define Device/phicomm_psg1218b
SOC := mt7620a
IMAGE_SIZE := 7872k