aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile11
-rw-r--r--target/linux/ramips/image/mt7621.mk2
-rw-r--r--target/linux/ramips/image/rt3883.mk2
3 files changed, 5 insertions, 10 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 0a32859bec..07251aebba 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -19,12 +19,12 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
KERNEL_LOADADDR := $(loadaddr-y)
-KERNEL_DTB = kernel-bin | patch-dtb | lzma
+KERNEL_DTB = kernel-bin | append-dtb | lzma
define Device/Default
- PROFILES = Default $$(DTS)
- KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
+ PROFILES = Default
KERNEL := $(KERNEL_DTB) | uImage lzma
DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $$(DTS)
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
@@ -52,11 +52,6 @@ define Build/jcg-header
mv $@.new $@
endef
-define Build/patch-dtb
- $(call Image/BuildDTB,../dts/$(DTS).dts,$@.dtb)
- $(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb
-endef
-
define Build/trx
$(STAGING_DIR_HOST)/bin/trx $(1) \
-o $@ \
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 36fafffd71..69f0e279d8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -98,7 +98,7 @@ define Device/dir-860l-b1
DTS := DIR-860L-B1
BLOCKSIZE := 64k
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
- KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-860L
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index b360a2d664..4150f96cf0 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -52,7 +52,7 @@ define Device/belkin_f9k1109v1
DEVICE_VARIANT := Version 1.0
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
IMAGE_SIZE := 7224k
- KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+ KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
# Stock firmware checks for this uImage image name during upload.
UIMAGE_NAME := N750F9K1103VB
endef