aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
-rw-r--r--target/linux/ramips/image/mt76x8.mk6
2 files changed, 9 insertions, 8 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 95efcca202..afb0502174 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -682,24 +682,25 @@ define Device/ubiquiti_edgerouterx-sfp
endef
TARGET_DEVICES += ubiquiti_edgerouterx-sfp
-define Device/unielec_u7621-06-256m-16m
+define Device/unielec_u7621-06-16m
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
- DEVICE_VARIANT := 256M RAM/16M flash
+ DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
- SUPPORTED_DEVICES += u7621-06-256M-16M
+ SUPPORTED_DEVICES += u7621-06-256M-16M unielec,u7621-06-256m-16m
endef
TARGET_DEVICES += unielec_u7621-06-256m-16m
-define Device/unielec_u7621-06-512m-64m
+define Device/unielec_u7621-06-64m
MTK_SOC := mt7621
IMAGE_SIZE := 65216k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
- DEVICE_VARIANT := 512M RAM/64M flash
+ DEVICE_VARIANT := 64M
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+ SUPPORTED_DEVICES += unielec,u7621-06-512m-64m
endef
TARGET_DEVICES += unielec_u7621-06-512m-64m
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 9ab16db064..4d126bcd06 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -454,14 +454,14 @@ define Device/tplink_tl-wr902ac-v3
endef
TARGET_DEVICES += tplink_tl-wr902ac-v3
-define Device/unielec_u7628-01-128m-16m
+define Device/unielec_u7628-01-16m
MTK_SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7628-01
- DEVICE_VARIANT := 128M RAM/16M flash
+ DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
- SUPPORTED_DEVICES += u7628-01-128M-16M
+ SUPPORTED_DEVICES += u7628-01-128M-16M unielec,u7628-01-128m-16m
endef
TARGET_DEVICES += unielec_u7628-01-128m-16m