aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile1
-rw-r--r--target/linux/ramips/image/mt7620.mk19
2 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 10e9edd3bb..bcd46d88a8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -187,6 +187,7 @@ define Device/Default
DEVICE_DTS_DIR := ../dts
DEVICE_DTS = $$(SOC)_$(1)
IMAGES := sysupgrade.bin
+ COMPILE :=
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 0cfaa95cf0..149b666aad 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -488,6 +488,25 @@ define Device/hnet_c108
endef
TARGET_DEVICES += hnet_c108
+define Device/hootoo_ht-tm05
+ SOC := mt7620n
+ IMAGE_SIZE := 6144k
+ DEVICE_VENDOR := HooToo
+ DEVICE_MODEL := HT-TM05
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-i2c-ralink
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x200000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile | pad-to 64k | lzma | \
+ uImage lzma
+ KERNEL := $(KERNEL_DTB) | uImage lzma -M 0x4f4b4c49
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | uImage lzma
+ IMAGES += kernel.bin rootfs.bin
+ IMAGE/kernel.bin := append-loader-okli $(1) | check-size 64k
+ IMAGE/rootfs.bin := $$(sysupgrade_bin) | check-size
+endef
+TARGET_DEVICES += hootoo_ht-tm05
+
define Device/iodata_wn-ac1167gr
SOC := mt7620a
DEVICE_VENDOR := I-O DATA