aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk10
-rw-r--r--target/linux/ramips/image/mt76x8.mk15
2 files changed, 15 insertions, 10 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index a8a5391216..abf2b1eed6 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -729,9 +729,10 @@ define Device/edimax_ew-7478apc
endef
TARGET_DEVICES += edimax_ew-7478apc
-define Device/tplink_c2-v1
+define Device/tplink_archer-c2-v1
$(Device/Archer)
DTS := ArcherC2-v1
+ SUPPORTED_DEVICES += tplink,c2-v1
TPLINK_FLASHLAYOUT := 8Mmtk
TPLINK_HWID := 0xc7500001
TPLINK_HWREV := 50
@@ -740,11 +741,12 @@ define Device/tplink_c2-v1
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
endef
-TARGET_DEVICES += tplink_c2-v1
+TARGET_DEVICES += tplink_archer-c2-v1
-define Device/tplink_c20-v1
+define Device/tplink_archer-c20-v1
$(Device/Archer)
DTS := ArcherC20v1
+ SUPPORTED_DEVICES += tplink,c20-v1
TPLINK_FLASHLAYOUT := 8Mmtk
TPLINK_HWID := 0xc2000001
TPLINK_HWREV := 0x44
@@ -754,7 +756,7 @@ define Device/tplink_c20-v1
DEVICE_VARIANT := v1
DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += tplink_c20-v1
+TARGET_DEVICES += tplink_archer-c20-v1
define Device/vonets_var11n-300
DTS := VAR11N-300
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 9ad77e83db..96b067e900 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -302,7 +302,7 @@ define Device/tplink_tl-wr841n-v14
endef
TARGET_DEVICES += tplink_tl-wr841n-v14
-define Device/tplink_c20-v4
+define Device/tplink_archer-c20-v4
$(Device/tplink)
DTS := ArcherC20v4
IMAGE_SIZE := 7808k
@@ -314,10 +314,11 @@ define Device/tplink_c20-v4
TPLINK_HWREVADD := 0x4
TPLINK_HVERSION := 3
DEVICE_PACKAGES := kmod-mt76x0e
+ SUPPORTED_DEVICES += tplink,c20-v4
endef
-TARGET_DEVICES += tplink_c20-v4
+TARGET_DEVICES += tplink_archer-c20-v4
-define Device/tplink_c50-v3
+define Device/tplink_archer-c50-v3
$(Device/tplink)
DTS := ArcherC50V3
IMAGE_SIZE := 7808k
@@ -329,10 +330,11 @@ define Device/tplink_c50-v3
TPLINK_HWREVADD := 0x1
TPLINK_HVERSION := 3
DEVICE_PACKAGES := kmod-mt76x2
+ SUPPORTED_DEVICES += tplink,c50-v3
endef
-TARGET_DEVICES += tplink_c50-v3
+TARGET_DEVICES += tplink_archer-c50-v3
-define Device/tplink_c50-v4
+define Device/tplink_archer-c50-v4
$(Device/tplink)
DTS := ArcherC50V4
IMAGE_SIZE := 7616k
@@ -345,8 +347,9 @@ define Device/tplink_c50-v4
TPLINK_HVERSION := 3
DEVICE_PACKAGES := kmod-mt76x2
IMAGES := sysupgrade.bin
+ SUPPORTED_DEVICES += tplink,c50-v4
endef
-TARGET_DEVICES += tplink_c50-v4
+TARGET_DEVICES += tplink_archer-c50-v4
define Device/tplink_tl-mr3020-v3
$(Device/tplink)