aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8ac78ad7de..b427ff4f25 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -4,6 +4,19 @@
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
+define Build/elecom-gst-factory
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ ( $(STAGING_DIR_HOST)/bin/mkhash md5 $@ | tr -d '\n' ) >> $@
+ ( \
+ echo -n "ELECOM $(product) v$(version)" | \
+ dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+ echo -n "MT7621_ELECOM_$(product)" >> $@
+endef
+
define Build/elecom-wrc-factory
$(eval product=$(word 1,$(1)))
$(eval version=$(word 2,$(1)))
@@ -104,6 +117,16 @@ define Device/elecom_wrc-1167ghbk2-s
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
+define Device/elecom_wrc-2533gst
+ DTS := WRC-2533GST
+ IMAGE_SIZE := 11264k
+ DEVICE_TITLE := ELECOM WRC-2533GST
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
+ elecom-gst-factory WRC-2533GST 0.00
+endef
+TARGET_DEVICES += elecom_wrc-2533gst
+
define Device/ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)