aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
-rw-r--r--target/linux/ramips/image/mt7620.mk13
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 36f95b6d1c..816146ece5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -147,6 +147,11 @@ define Build/sercom-footer
$(call Build/sercom-seal,-f)
endef
+define Build/fonfxcimage
+ uimage_padhdr -i $@ -o $@.new
+ mv $@.new $@
+endef
+
ifeq ($(SUBTARGET),rt288x)
include rt288x.mk
endif
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d7b06076da..455f836168 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -372,6 +372,19 @@ define Device/elecom_wrh-300cr
endef
TARGET_DEVICES += elecom_wrh-300cr
+define Device/fon_fon2601
+ MTK_SOC := mt7620a
+ IMAGE_SIZE := 15936k
+ DEVICE_VENDOR := Fon
+ DEVICE_MODEL := FON2601
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
+ KERNEL_INITRAMFS := $$(KERNEL) | fonfxcimage
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs |\
+ fonfxcimage |\
+ pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += fon_fon2601
+
define Device/glinet_gl-mt300a
MTK_SOC := mt7620a
IMAGE_SIZE := 15872k