aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk31
1 files changed, 21 insertions, 10 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 41b2c3dd5f..b360a2d664 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -12,7 +12,8 @@ define Device/br-6475nd
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
append-metadata | check-size $$$$(IMAGE_SIZE)
- DEVICE_TITLE := Edimax BR-6475nD
+ DEVICE_VENDOR := Edimax
+ DEVICE_MODEL := BR-6475nD
DEVICE_PACKAGES := swconfig
endef
TARGET_DEVICES += br-6475nd
@@ -23,7 +24,8 @@ define Device/cy-swr1100
BLOCKSIZE := 64k
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgnd10_samsung_ss815
- DEVICE_TITLE := Samsung CY-SWR1100
+ DEVICE_VENDOR := Samsung
+ DEVICE_MODEL := CY-SWR1100
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
TARGET_DEVICES += cy-swr1100
@@ -35,7 +37,8 @@ define Device/dir-645
BLOCKSIZE := 4k
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
- DEVICE_TITLE := D-Link DIR-645
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DIR-645
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
TARGET_DEVICES += dir-645
@@ -44,7 +47,9 @@ TARGET_DEVICES += dir-645
define Device/belkin_f9k1109v1
DTS := F9K1109V1
BLOCKSIZE := 64k
- DEVICE_TITLE := Belkin F9K1109 Version 1.0
+ DEVICE_VENDOR := Belkin
+ DEVICE_MODEL := F9K1109
+ DEVICE_VARIANT := Version 1.0
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
IMAGE_SIZE := 7224k
KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
@@ -57,7 +62,8 @@ define Device/hpm
DTS := HPM
BLOCKSIZE := 64k
IMAGE_SIZE := 16064k
- DEVICE_TITLE := Omnima HPM
+ DEVICE_VENDOR := Omnima
+ DEVICE_MODEL := HPM
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
endef
TARGET_DEVICES += hpm
@@ -67,7 +73,8 @@ define Device/rt-n56u
DTS := RT-N56U
BLOCKSIZE := 64k
IMAGE/sysupgrade.bin += | mkrtn56uimg -s
- DEVICE_TITLE := Asus RT-N56U
+ DEVICE_VENDOR := Asus
+ DEVICE_MODEL := RT-N56U
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
TARGET_DEVICES += rt-n56u
@@ -79,7 +86,8 @@ define Device/tew-691gr
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
umedia-header 0x026910
- DEVICE_TITLE := TRENDnet TEW-691GR
+ DEVICE_VENDOR := TRENDnet
+ DEVICE_MODEL := TEW-691GR
DEVICE_PACKAGES := swconfig
endef
TARGET_DEVICES += tew-691gr
@@ -91,7 +99,8 @@ define Device/tew-692gr
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
umedia-header 0x026920
- DEVICE_TITLE := TRENDnet TEW-692GR
+ DEVICE_VENDOR := TRENDnet
+ DEVICE_MODEL := TEW-692GR
DEVICE_PACKAGES := swconfig
endef
TARGET_DEVICES += tew-692gr
@@ -104,7 +113,8 @@ define Device/wlr-6000
IMAGES += factory.dlf
IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
senao-header -r 0x0202 -p 0x41 -t 2
- DEVICE_TITLE := Sitecom WLR-6000
+ DEVICE_VENDOR := Sitecom
+ DEVICE_MODEL := WLR-6000
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
TARGET_DEVICES += wlr-6000
@@ -113,6 +123,7 @@ TARGET_DEVICES += wlr-6000
define Device/wmdr-143n
DTS := WMDR-143N
BLOCKSIZE := 64k
- DEVICE_TITLE := Loewe WMDR-143N
+ DEVICE_VENDOR := Loewe
+ DEVICE_MODEL := WMDR-143N
endef
TARGET_DEVICES += wmdr-143n