aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index abee533d01..41b2c3dd5f 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -41,6 +41,18 @@ endef
TARGET_DEVICES += dir-645
+define Device/belkin_f9k1109v1
+ DTS := F9K1109V1
+ BLOCKSIZE := 64k
+ DEVICE_TITLE := Belkin F9K1109 Version 1.0
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ IMAGE_SIZE := 7224k
+ KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+ # Stock firmware checks for this uImage image name during upload.
+ UIMAGE_NAME := N750F9K1103VB
+endef
+TARGET_DEVICES += belkin_f9k1109v1
+
define Device/hpm
DTS := HPM
BLOCKSIZE := 64k