aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk117
1 files changed, 55 insertions, 62 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 0adb39eab1..d96224e425 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -5,33 +5,30 @@ define Build/mkrtn56uimg
$(STAGING_DIR_HOST)/bin/mkrtn56uimg $(1) $@
endef
-define Device/edimax_br-6475nd
+define Device/asus_rt-n56u
MTK_SOC := rt3883
BLOCKSIZE := 64k
- IMAGE_SIZE := 7744k
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
- edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
- DEVICE_VENDOR := Edimax
- DEVICE_MODEL := BR-6475nD
- DEVICE_PACKAGES := swconfig
- SUPPORTED_DEVICES += br-6475nd
+ IMAGE/sysupgrade.bin += | mkrtn56uimg -s
+ DEVICE_VENDOR := Asus
+ DEVICE_MODEL := RT-N56U
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += rt-n56u
endef
-TARGET_DEVICES += edimax_br-6475nd
+TARGET_DEVICES += asus_rt-n56u
-define Device/samsung_cy-swr1100
- $(Device/seama)
+define Device/belkin_f9k1109v1
MTK_SOC := rt3883
BLOCKSIZE := 64k
- KERNEL := $(KERNEL_DTB)
- SEAMA_SIGNATURE := wrgnd10_samsung_ss815
- DEVICE_VENDOR := Samsung
- DEVICE_MODEL := CY-SWR1100
+ DEVICE_VENDOR := Belkin
+ DEVICE_MODEL := F9K1109
+ DEVICE_VARIANT := Version 1.0
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
- SUPPORTED_DEVICES += cy-swr1100
+ IMAGE_SIZE := 7224k
+ KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
+ # Stock firmware checks for this uImage image name during upload.
+ UIMAGE_NAME := N750F9K1103VB
endef
-TARGET_DEVICES += samsung_cy-swr1100
-
+TARGET_DEVICES += belkin_f9k1109v1
define Device/dlink_dir-645
$(Device/seama)
@@ -46,20 +43,28 @@ define Device/dlink_dir-645
endef
TARGET_DEVICES += dlink_dir-645
+define Device/edimax_br-6475nd
+ MTK_SOC := rt3883
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 7744k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_VENDOR := Edimax
+ DEVICE_MODEL := BR-6475nD
+ DEVICE_PACKAGES := swconfig
+ SUPPORTED_DEVICES += br-6475nd
+endef
+TARGET_DEVICES += edimax_br-6475nd
-define Device/belkin_f9k1109v1
+define Device/loewe_wmdr-143n
MTK_SOC := rt3883
BLOCKSIZE := 64k
- DEVICE_VENDOR := Belkin
- DEVICE_MODEL := F9K1109
- DEVICE_VARIANT := Version 1.0
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
- IMAGE_SIZE := 7224k
- KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
- # Stock firmware checks for this uImage image name during upload.
- UIMAGE_NAME := N750F9K1103VB
+ DEVICE_VENDOR := Loewe
+ DEVICE_MODEL := WMDR-143N
+ SUPPORTED_DEVICES += wmdr-143n
endef
-TARGET_DEVICES += belkin_f9k1109v1
+TARGET_DEVICES += loewe_wmdr-143n
define Device/omnima_hpm
MTK_SOC := rt3883
@@ -72,18 +77,32 @@ define Device/omnima_hpm
endef
TARGET_DEVICES += omnima_hpm
-
-define Device/asus_rt-n56u
+define Device/samsung_cy-swr1100
+ $(Device/seama)
MTK_SOC := rt3883
BLOCKSIZE := 64k
- IMAGE/sysupgrade.bin += | mkrtn56uimg -s
- DEVICE_VENDOR := Asus
- DEVICE_MODEL := RT-N56U
+ KERNEL := $(KERNEL_DTB)
+ SEAMA_SIGNATURE := wrgnd10_samsung_ss815
+ DEVICE_VENDOR := Samsung
+ DEVICE_MODEL := CY-SWR1100
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
- SUPPORTED_DEVICES += rt-n56u
+ SUPPORTED_DEVICES += cy-swr1100
endef
-TARGET_DEVICES += asus_rt-n56u
+TARGET_DEVICES += samsung_cy-swr1100
+define Device/sitecom_wlr-6000
+ MTK_SOC := rt3883
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7244k
+ IMAGES += factory.dlf
+ IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ senao-header -r 0x0202 -p 0x41 -t 2
+ DEVICE_VENDOR := Sitecom
+ DEVICE_MODEL := WLR-6000
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += wlr-6000
+endef
+TARGET_DEVICES += sitecom_wlr-6000
define Device/trendnet_tew-691gr
MTK_SOC := rt3883
@@ -98,7 +117,6 @@ define Device/trendnet_tew-691gr
endef
TARGET_DEVICES += trendnet_tew-691gr
-
define Device/trendnet_tew-692gr
MTK_SOC := rt3883
BLOCKSIZE := 64k
@@ -111,28 +129,3 @@ define Device/trendnet_tew-692gr
SUPPORTED_DEVICES += tew-692gr
endef
TARGET_DEVICES += trendnet_tew-692gr
-
-
-define Device/sitecom_wlr-6000
- MTK_SOC := rt3883
- BLOCKSIZE := 4k
- IMAGE_SIZE := 7244k
- IMAGES += factory.dlf
- IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
- senao-header -r 0x0202 -p 0x41 -t 2
- DEVICE_VENDOR := Sitecom
- DEVICE_MODEL := WLR-6000
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
- SUPPORTED_DEVICES += wlr-6000
-endef
-TARGET_DEVICES += sitecom_wlr-6000
-
-
-define Device/loewe_wmdr-143n
- MTK_SOC := rt3883
- BLOCKSIZE := 64k
- DEVICE_VENDOR := Loewe
- DEVICE_MODEL := WMDR-143N
- SUPPORTED_DEVICES += wmdr-143n
-endef
-TARGET_DEVICES += loewe_wmdr-143n