aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 69533ce9e7..62ced9b7de 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -850,3 +850,12 @@ define Device/xdxrn502j
DEVICE_TITLE := XDX RN502J
endef
TARGET_DEVICES += xdxrn502j
+
+define Device/kn
+ DTS := kn
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := ZyXEL Keenetic
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += kn