aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk46
1 files changed, 26 insertions, 20 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 29c2613685..59559c4164 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -79,6 +79,32 @@ define Device/buffalo_wcr-1166ds
endef
TARGET_DEVICES += buffalo_wcr-1166ds
+define Device/comfast_cf-wr758ac
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := COMFAST
+ DEVICE_MODEL := CF-WR758AC
+ DEVICE_ALT0_VENDOR := Joowin
+ DEVICE_ALT0_MODEL := JW-WR758AC
+endef
+
+define Device/comfast_cf-wr758ac-v1
+ $(Device/comfast_cf-wr758ac)
+ DEVICE_PACKAGES := kmod-mt76x2
+ DEVICE_VARIANT := V1
+ DEVICE_ALT0_VARIANT := V1
+ SUPPORTED_DEVICES += joowin,jw-wr758ac-v1
+endef
+TARGET_DEVICES += comfast_cf-wr758ac-v1
+
+define Device/comfast_cf-wr758ac-v2
+ $(Device/comfast_cf-wr758ac)
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+ DEVICE_VARIANT := V2
+ DEVICE_ALT0_VARIANT := V2
+ SUPPORTED_DEVICES += joowin,jw-wr758ac-v2
+endef
+TARGET_DEVICES += comfast_cf-wr758ac-v2
+
define Device/cudy_wr1000
IMAGE_SIZE := 7872k
IMAGES += factory.bin
@@ -220,26 +246,6 @@ define Device/iptime_a604m
endef
TARGET_DEVICES += iptime_a604m
-define Device/joowin_jw-wr758ac
- IMAGE_SIZE := 7872k
- DEVICE_VENDOR := Joowin
- DEVICE_MODEL := WR758AC
-endef
-
-define Device/joowin_jw-wr758ac-v1
- $(Device/joowin_jw-wr758ac)
- DEVICE_PACKAGES := kmod-mt76x2
- DEVICE_VARIANT := V1
-endef
-TARGET_DEVICES += joowin_jw-wr758ac-v1
-
-define Device/joowin_jw-wr758ac-v2
- $(Device/joowin_jw-wr758ac)
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
- DEVICE_VARIANT := V2
-endef
-TARGET_DEVICES += joowin_jw-wr758ac-v2
-
define Device/jotale_js76x8
DEVICE_VENDOR := Jotale
DEVICE_MODEL := JS76x8