aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 2b5ec60a90..f3a948bf11 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -282,6 +282,21 @@ define Device/tplink_archer-c20-v4
endef
TARGET_DEVICES += tplink_archer-c20-v4
+define Device/tplink_archer-c20-v5
+ $(Device/tplink)
+ IMAGE_SIZE := 7616k
+ DEVICE_MODEL := Archer C20
+ DEVICE_VARIANT := v5
+ TPLINK_FLASHLAYOUT := 8MSUmtk
+ TPLINK_HWID := 0xc200005
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-mt76x0e
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += tplink_archer-c20-v5
+
define Device/tplink_archer-c50-v3
$(Device/tplink)
IMAGE_SIZE := 7808k