aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index e9188e7405..29c2613685 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -220,6 +220,26 @@ define Device/iptime_a604m
endef
TARGET_DEVICES += iptime_a604m
+define Device/joowin_jw-wr758ac
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Joowin
+ DEVICE_MODEL := WR758AC
+endef
+
+define Device/joowin_jw-wr758ac-v1
+ $(Device/joowin_jw-wr758ac)
+ DEVICE_PACKAGES := kmod-mt76x2
+ DEVICE_VARIANT := V1
+endef
+TARGET_DEVICES += joowin_jw-wr758ac-v1
+
+define Device/joowin_jw-wr758ac-v2
+ $(Device/joowin_jw-wr758ac)
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+ DEVICE_VARIANT := V2
+endef
+TARGET_DEVICES += joowin_jw-wr758ac-v2
+
define Device/jotale_js76x8
DEVICE_VENDOR := Jotale
DEVICE_MODEL := JS76x8