aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index bd91bd9340..81b68f6354 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -47,6 +47,19 @@ define Device/asus_rt-ac1200
endef
TARGET_DEVICES += asus_rt-ac1200
+define Device/asus_rt-ac1200-v2
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Asus
+ DEVICE_MODEL := RT-AC1200
+ DEVICE_VARIANT := V2
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+endef
+TARGET_DEVICES += asus_rt-ac1200-v2
+
define Device/asus_rt-n10p-v3
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Asus