aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5459288341..30c41420aa 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -482,6 +482,22 @@ define Device/tplink_tl-mr3420-v5
endef
TARGET_DEVICES += tplink_tl-mr3420-v5
+define Device/tplink_tl-mr6400-v4
+ $(Device/tplink-v2)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := TL-MR6400
+ DEVICE_VARIANT := v4
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x64000004
+ TPLINK_HWREV := 0x4
+ TPLINK_HWREVADD := 0x4
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport \
+ kmod-usb-serial kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi
+ IMAGES := sysupgrade.bin tftp-recovery.bin
+ IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-mr6400-v4
+
define Device/tplink_tl-wa801nd-v5
$(Device/tplink-v2)
IMAGE_SIZE := 7808k