aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index aa7adeee60..f79ba5fb5a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,6 +2,7 @@
# MT7621 Profiles
#
+include ./common-sercomm.mk
include ./common-tp-link.mk
DEFAULT_SOC := mt7621
@@ -285,6 +286,19 @@ define Device/beeline_smartbox-flash
endef
TARGET_DEVICES += beeline_smartbox-flash
+define Device/beeline_smartbox-giga
+ $(Device/sercomm_dxx)
+ IMAGE_SIZE := 24576k
+ SERCOMM_HWID := DBE
+ SERCOMM_HWVER := 10100
+ SERCOMM_SWVER := 1001
+ DEVICE_VENDOR := Beeline
+ DEVICE_MODEL := SmartBox GIGA
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-usb3 uboot-envtools
+endef
+TARGET_DEVICES += beeline_smartbox-giga
+
define Device/buffalo_wsr-1166dhp
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)