aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fa4c83dbe1..2675c7d08b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -178,6 +178,18 @@ define Device/afoundry_ew1200
endef
TARGET_DEVICES += afoundry_ew1200
+define Device/alfa-network_ax1800rm
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 15488k
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := AX1800RM
+ DEVICE_PACKAGES := kmod-mt7915-firmware
+ KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGES += recovery.bin
+ IMAGE/recovery.bin := append-kernel | append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += alfa-network_ax1800rm
+
define Device/alfa-network_quad-e4g
$(Device/dsa-migration)
IMAGE_SIZE := 16064k