aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d7a4b9fa7c..728b2efb24 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -261,6 +261,24 @@ define Device/edimax_ra21s
endef
TARGET_DEVICES += edimax_ra21s
+define Device/edimax_re23s
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 15680k
+ DEVICE_VENDOR := Edimax
+ DEVICE_MODEL := RE23S
+ DEVICE_ALT0_VENDOR := Edimax
+ DEVICE_ALT0_MODEL := Gemini RE23S
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN76 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ append-metadata | check-size
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN76 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ check-size
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += edimax_re23s
+
define Device/edimax_rg21s
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Edimax