aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4d2f2a3610..34eac32112 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -95,6 +95,13 @@ define Build/zytrx-header
mv $@.new $@
endef
+define Build/zyxel-nwa-fit
+ $(TOPDIR)/scripts/mkits-zyxel-fit.sh \
+ $@.its $@ "6b e1 6f e1 ff ff ff ff ff ff"
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
+ @mv $@.new $@
+endef
+
define Device/dsa-migration
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
@@ -2211,6 +2218,33 @@ define Device/zyxel_nr7101
endef
TARGET_DEVICES += zyxel_nr7101
+define Device/zyxel_nwa-ax
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := ZyXEL
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 8192k
+ UBINIZE_OPTS := -E 5
+ DEVICE_PACKAGES := kmod-mt7915e uboot-envtools zyxel-bootconfig
+ KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGES += factory.bin ramboot-factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | zyxel-nwa-fit
+ IMAGE/ramboot-factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+
+define Device/zyxel_nwa50ax
+ $(Device/zyxel_nwa-ax)
+ DEVICE_MODEL := NWA50AX
+endef
+TARGET_DEVICES += zyxel_nwa50ax
+
+define Device/zyxel_nwa55axe
+ $(Device/zyxel_nwa-ax)
+ DEVICE_MODEL := NWA55AXE
+endef
+TARGET_DEVICES += zyxel_nwa55axe
+
define Device/zyxel_wap6805
$(Device/dsa-migration)
BLOCKSIZE := 128k