aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2907d90dab..961f8a3b75 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1878,6 +1878,23 @@ define Device/wavlink_wl-wn533a8
endef
TARGET_DEVICES += wavlink_wl-wn533a8
+define Device/wavlink_ws-wn572hp3-4g
+ $(Device/dsa-migration)
+ BLOCKSIZE := 64k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WS-WN572HP3
+ DEVICE_VARIANT := 4G
+ IMAGE_SIZE := 15040k
+ KERNEL_LOADADDR := 0x82000000
+ KERNEL := kernel-bin | relocate-kernel 0x80001000 | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-usb3 kmod-usb-net-rndis comgt-ncm
+endef
+TARGET_DEVICES += wavlink_ws-wn572hp3-4g
+
define Device/wevo_11acnas
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)