aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 18a29270d7..46097f231e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1284,6 +1284,23 @@ define Device/planex_vr500
endef
TARGET_DEVICES += planex_vr500
+define Device/raisecom_msg1500-x-00
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 129280k
+ UBINIZE_OPTS := -E 5
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := RAISECOM
+ DEVICE_MODEL := MSG1500
+ DEVICE_VARIANT := X.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3 \
+ kmod-usb-ledtrig-usbport uboot-envtools
+endef
+TARGET_DEVICES += raisecom_msg1500-x-00
+
define Device/samknows_whitebox-v8
$(Device/dsa-migration)
IMAGE_SIZE := 16064k