aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 35c5627264..e1cb0195b0 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -766,6 +766,23 @@ define Device/iptime_a3004ns-dual
endef
TARGET_DEVICES += iptime_a3004ns-dual
+define Device/iptime_a3004t
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ FILESYSTEMS := squashfs
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 129280k
+ UIMAGE_NAME := a3004t
+ UBINIZE_OPTS := -E 5
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A3004T
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3
+endef
+TARGET_DEVICES += iptime_a3004t
+
define Device/iptime_a6ns-m
$(Device/dsa-migration)
IMAGE_SIZE := 16128k