aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index cc0eb1d279..cf81a862ff 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -235,6 +235,17 @@ define Device/dlink_dir-8xx-a1
check-size
endef
+define Device/dlink_dir-8xx-r1
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := D-Link
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs |\
+ pad-rootfs | append-metadata | check-size
+endef
+
define Device/dlink_dir-xx60-a1
$(Device/dsa-migration)
BLOCKSIZE := 128k
@@ -312,6 +323,17 @@ define Device/dlink_dir-882-a1
endef
TARGET_DEVICES += dlink_dir-882-a1
+define Device/dlink_dir-882-r1
+ $(Device/dlink_dir-8xx-r1)
+ DEVICE_MODEL := DIR-882
+ DEVICE_VARIANT := R1
+ DEVICE_PACKAGES += kmod-usb3 kmod-usb-ledtrig-usbport
+ IMAGE/factory.bin := append-kernel | append-rootfs | check-size | \
+ sign-dlink-ru 57c5375741c30ca9ebcb36713db4ba51 \
+ ab0dff19af8842cdb70a86b4b68d23f7
+endef
+TARGET_DEVICES += dlink_dir-882-r1
+
define Device/d-team_newifi-d2
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)