aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1b7d095fc4..011a96a59e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1359,6 +1359,17 @@ define Device/raisecom_msg1500-x-00
endef
TARGET_DEVICES += raisecom_msg1500-x-00
+define Device/renkforce_ws-wn530hp3-a
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Renkforce
+ DEVICE_MODEL := WS-WN530HP3-A
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 65536 | append-rootfs | \
+ check-size | append-metadata
+ IMAGE_SIZE := 15040k
+endef
+TARGET_DEVICES += renkforce_ws-wn530hp3-a
+
define Device/samknows_whitebox-v8
$(Device/dsa-migration)
IMAGE_SIZE := 16064k