aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 48561d5ff9..a16900aa8c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -326,6 +326,30 @@ define Device/elecom_wrc-1167ghbk2-s
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
+define Device/elecom_wrc-1750gs
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 11264k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-1750GS
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elecom-gst-factory WRC-1750GS 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += elecom_wrc-1750gs
+
+define Device/elecom_wrc-1750gsv
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 11264k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-1750GSV
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elecom-gst-factory WRC-1750GSV 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += elecom_wrc-1750gsv
+
define Device/elecom_wrc-1900gst
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 11264k