aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 82fbd87df9..98d83f944f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -595,6 +595,21 @@ define Device/netgear_r6350
endef
TARGET_DEVICES += netgear_r6350
+define Device/netgear_r6700-v2
+ $(Device/netgear_sercomm_nand)
+ DEVICE_MODEL := R6700
+ DEVICE_VARIANT := v2
+ DEVICE_ALT0_VENDOR := NETGEAR
+ DEVICE_ALT0_MODEL := Nighthawk AC2400
+ SERCOMM_HWNAME := R6950
+ SERCOMM_HWID := BZV
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x1032
+ IMAGE_SIZE := 40960k
+ DEVICE_PACKAGES += kmod-mt7615e
+endef
+TARGET_DEVICES += netgear_r6700-v2
+
define Device/netgear_r6800
$(Device/netgear_sercomm_nand)
DEVICE_MODEL := R6800