aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk16
1 files changed, 11 insertions, 5 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 17a536e69f..fbf37144b9 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -61,13 +61,18 @@ TARGET_DEVICES += alfa-network_tube-e4g
define Device/amit_jboot
DLINK_IMAGE_OFFSET := 0x10000
- KERNEL := $(KERNEL_DTB)
- KERNEL_SIZE := 2048k
+ KERNEL := $(KERNEL_DTB) | uImage lzma -M 0x4f4b4c49
+ LOADER_FLASH_OFFS := 0x20000
+ LOADER_TYPE := bin
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile | pad-to 64k | lzma | \
+ pad-to 65480
IMAGES += factory.bin
- IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
- IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | mkdlinkfw-loader | \
+ pad-rootfs | append-metadata
+ IMAGE/factory.bin := append-kernel | append-rootfs | mkdlinkfw-loader | \
+ pad-rootfs | mkdlinkfw-factory
DEVICE_PACKAGES := jboot-tools kmod-usb2 kmod-usb-ohci
- DEFAULT := n
endef
define Device/asus_rp-n53
@@ -194,6 +199,7 @@ define Device/dlink_dir-510l
$(Device/amit_jboot)
SOC := mt7620a
IMAGE_SIZE := 14208k
+ LOADER_FLASH_OFFS := 0x220000
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-510L
DEVICE_PACKAGES += kmod-mt76x0e