aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c758da5795..498170236a 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -526,6 +526,20 @@ define Device/hnet_c108
endef
TARGET_DEVICES += hnet_c108
+define Device/humax_e2
+ SOC := mt7620a
+ IMAGE_SIZE := 7744k
+ DEVICE_VENDOR := HUMAX
+ DEVICE_MODEL := E2
+ DEVICE_ALT0_VENDOR := HUMAX
+ DEVICE_ALT0_MODEL := QUANTUM E2
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN75 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += humax_e2
+
define Device/sunvalley_filehub_common
SOC := mt7620n
IMAGE_SIZE := 6144k