aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d523a62e0b..ac256cf1ae 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -89,6 +89,16 @@ define Build/mkdlinkfw-factory
mv $@.new $@
endef
+define Build/mkdlinkfw-loader
+ -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+ -k $(KDIR)/loader-$(DEVICE_NAME).bin \
+ -r $@ \
+ -o $@.new \
+ $(if $(DLINK_IMAGE_OFFSET), -O $(DLINK_IMAGE_OFFSET)) \
+ -s $(DLINK_FIRMWARE_SIZE)
+ mv $@.new $@
+endef
+
define Build/netis-tail
echo -n $(1) >> $@
echo -n $(UIMAGE_NAME)-yun | $(MKHASH) md5 | \