aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 93ce59e262..3ee9828a64 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -51,11 +51,6 @@ define Build/elx-header
rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
endef
-define Build/fonfxcimage
- uimage_padhdr -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Build/jcg-header
$(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
$(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
@@ -151,6 +146,11 @@ define Build/trx
-a 4 -f $(IMAGE_ROOTFS)
endef
+define Build/uimage-padhdr
+ uimage_padhdr $(if $(1),-l $(1)) -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef