aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 3671caef9d..d523a62e0b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -144,6 +144,12 @@ define Build/uimage-padhdr
mv $@.new $@
endef
+define Build/uimage-sgehdr
+ uimage_sgehdr -i $@ -o $@.new -m $(DEVICE_MODEL) \
+ -h $(DEVICE_VARIANT) -s V1.00000
+ mv $@.new $@
+endef
+
define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef