aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pistachio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pistachio/Makefile')
-rw-r--r--target/linux/pistachio/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/pistachio/Makefile b/target/linux/pistachio/Makefile
new file mode 100644
index 0000000000..630fb56fd3
--- /dev/null
+++ b/target/linux/pistachio/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=pistachio
+BOARDNAME:=MIPS pistachio
+FEATURES:=fpu usb usbgadget squashfs targz nand
+CPU_TYPE:=24kc
+CPU_SUBTYPE:=24kf
+MAINTAINER:=
+
+KERNEL_PATCHVER:=4.9
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=vmlinux dtbs
+
+DEFAULT_PACKAGES += \
+ kmod-gpio-button-hotplug \
+ uboot-envtools
+
+$(eval $(call BuildTarget))