aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/ieee80211-dscape/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/package/ieee80211-dscape/src/Makefile')
-rw-r--r--target/linux/package/ieee80211-dscape/src/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/package/ieee80211-dscape/src/Makefile b/target/linux/package/ieee80211-dscape/src/Makefile
new file mode 100644
index 0000000000..ac4ab887ba
--- /dev/null
+++ b/target/linux/package/ieee80211-dscape/src/Makefile
@@ -0,0 +1,23 @@
+obj-$(CONFIG_IEEE80211) += 80211.o rate_control.o
+
+80211-objs := \
+ ieee80211.o \
+ ieee80211_ioctl.o \
+ sta_info.o \
+ wep.o \
+ wpa.o \
+ ieee80211_proc.o \
+ ieee80211_scan.o \
+ ieee80211_sta.o \
+ michael.o \
+ tkip.o \
+ aes_ccm.o \
+ wme.o
+
+ifeq ($(CONFIG_NET_SCHED),)
+ 80211-objs += fifo_qdisc.o
+endif
+
+ifeq ($(CONFIG_IEEE80211_LEDS),y)
+ 80211-objs += ieee80211_led.o
+endif