aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/bcm43xx-standalone/fwcutter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/package/bcm43xx-standalone/fwcutter/Makefile')
-rw-r--r--target/linux/package/bcm43xx-standalone/fwcutter/Makefile32
1 files changed, 0 insertions, 32 deletions
diff --git a/target/linux/package/bcm43xx-standalone/fwcutter/Makefile b/target/linux/package/bcm43xx-standalone/fwcutter/Makefile
deleted file mode 100644
index 6402dca85f..0000000000
--- a/target/linux/package/bcm43xx-standalone/fwcutter/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-VERSION = 0.0.1
-
-FIRMWARE_INSTALL_DIR ?= /lib/firmware
-
-CC = cc
-PREFIX = /usr/local
-CFLAGS = -std=c99 -O2 -fomit-frame-pointer -Wall -pedantic -D_BSD_SOURCE
-LDFLAGS =
-
-
-OBJECTS = fwcutter.o md5.o
-
-CFLAGS += -DFWCUTTER_VERSION_=$(VERSION)
-
-all: fwcutter
-
-fwcutter: $(OBJECTS)
- $(CC) $(CFLAGS) -o fwcutter $(OBJECTS) $(LDFLAGS)
-
-install: all
- -install -o 0 -g 0 -m 755 fwcutter $(PREFIX)/bin/
-
-clean:
- -rm -f *~ *.o *.orig *.rej *.fw fwcutter
-
-installfw:
- -if ! [ -d $(FIRMWARE_INSTALL_DIR) ]; then mkdir $(FIRMWARE_INSTALL_DIR); fi
- -install -o 0 -g 0 -m 600 bcm43xx_*.fw $(FIRMWARE_INSTALL_DIR)
-
-# dependencies
-fwcutter.o: md5.h fwcutter_list.h
-md5.o: md5.h