aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch b/target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch
new file mode 100644
index 0000000000..cf272f76b7
--- /dev/null
+++ b/target/linux/oxnas/patches-5.4/320-oxnas-phy-pcie.patch
@@ -0,0 +1,44 @@
+--- a/arch/arm/boot/dts/ox820.dtsi
++++ b/arch/arm/boot/dts/ox820.dtsi
+@@ -247,6 +247,15 @@
+ };
+ };
+
++ pcie_phy: pcie-phy@a00000 {
++ compatible = "oxsemi,ox820-pcie-phy";
++ reg = <0xa00000 0x10>;
++ #phy-cells = <0>;
++ resets = <&reset RESET_PCIEPHY>;
++ reset-names = "phy";
++ status = "disabled";
++ };
++
+ sys: sys-ctrl@e00000 {
+ compatible = "oxsemi,ox820-sys-ctrl", "syscon", "simple-mfd";
+ reg = <0xe00000 0x200000>;
+--- a/drivers/phy/Kconfig
++++ b/drivers/phy/Kconfig
+@@ -35,6 +35,13 @@ config PHY_LPC18XX_USB_OTG
+ This driver is need for USB0 support on LPC18xx/43xx and takes
+ care of enabling and clock setup.
+
++config PHY_OXNAS
++ tristate "Oxford Semi. OX820 PCI-E PHY support"
++ depends on HAS_IOMEM && OF && (ARM || COMPILE_TEST)
++ select GENERIC_PHY
++ help
++ This option enables support for OXNAS OX820 SoC PCIE PHY.
++
+ config PHY_PISTACHIO_USB
+ tristate "IMG Pistachio USB2.0 PHY driver"
+ depends on MACH_PISTACHIO
+--- a/drivers/phy/Makefile
++++ b/drivers/phy/Makefile
+@@ -6,6 +6,7 @@
+ obj-$(CONFIG_GENERIC_PHY) += phy-core.o
+ obj-$(CONFIG_GENERIC_PHY_MIPI_DPHY) += phy-core-mipi-dphy.o
+ obj-$(CONFIG_PHY_LPC18XX_USB_OTG) += phy-lpc18xx-usb-otg.o
++obj-$(CONFIG_PHY_OXNAS) += phy-oxnas-pcie.o
+ obj-$(CONFIG_PHY_XGENE) += phy-xgene.o
+ obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
+ obj-$(CONFIG_ARCH_SUNXI) += allwinner/