aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.14/150-oxnas-restart.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.14/150-oxnas-restart.patch')
-rw-r--r--target/linux/oxnas/patches-4.14/150-oxnas-restart.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.14/150-oxnas-restart.patch b/target/linux/oxnas/patches-4.14/150-oxnas-restart.patch
new file mode 100644
index 0000000000..dafa967592
--- /dev/null
+++ b/target/linux/oxnas/patches-4.14/150-oxnas-restart.patch
@@ -0,0 +1,25 @@
+--- a/drivers/power/reset/Kconfig
++++ b/drivers/power/reset/Kconfig
+@@ -113,6 +113,12 @@ config POWER_RESET_MSM
+ help
+ Power off and restart support for Qualcomm boards.
+
++config POWER_RESET_OXNAS
++ bool "OXNAS SoC restart driver"
++ depends on ARCH_OXNAS
++ help
++ Restart support for OXNAS boards.
++
+ config POWER_RESET_PIIX4_POWEROFF
+ tristate "Intel PIIX4 power-off driver"
+ depends on PCI
+--- a/drivers/power/reset/Makefile
++++ b/drivers/power/reset/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_POWER_RESET_GPIO_RESTART) +
+ obj-$(CONFIG_POWER_RESET_HISI) += hisi-reboot.o
+ obj-$(CONFIG_POWER_RESET_IMX) += imx-snvs-poweroff.o
+ obj-$(CONFIG_POWER_RESET_MSM) += msm-poweroff.o
++obj-$(CONFIG_POWER_RESET_OXNAS) += oxnas-restart.o
+ obj-$(CONFIG_POWER_RESET_PIIX4_POWEROFF) += piix4-poweroff.o
+ obj-$(CONFIG_POWER_RESET_LTC2952) += ltc2952-poweroff.o
+ obj-$(CONFIG_POWER_RESET_QNAP) += qnap-poweroff.o